Back to overview
Degraded
We're starting to see signs of recovery across services
May 8, 2026 at 2:37am UTC
Affected services
SwitchX API
Beeble Web
Beeble Platform
SwitchX
Resolved
May 8, 2026 at 5:28am UTC
All services are recovered
Affected services
Created
May 8, 2026 at 2:37am UTC
We're starting to see signs of recovery across services
Affected services